Issue with DMARC Processing
Incident Report for MxToolbox, Inc.
Resolved
We had an issue that started Friday evening that stopped the processing of inbound DMARC reports. This issue has been resolved and we are currently in the process of backfilling the DMARC data. We apologize for the inconvenience.
Posted Aug 29, 2022 - 10:43 CDT
This incident affected: MXDelivery Center.