User Interface / Dashboard Issue

Incident Report for MxToolbox, Inc.

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 11:20 CDT

Update

We are continuing to monitor for any further issues.
Posted Apr 18, 2025 - 11:20 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2025 - 17:19 CDT

Investigating

We are currently investigating an issue with the Delivery Center UI / Dashboard that is causing some links and buttons to not function. The DMARC Data is not impacted, it is just the functionality with certain links and buttons, and DMARC Performance filters.
Posted Apr 11, 2025 - 12:25 CDT
This incident affected: MXDelivery Center.