Amazon Hosting Outage & Login Issues.
Incident Report for MxToolbox, Inc.
Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 21:51 CST
Update
We have confirmed all of our services are operational again.
Posted Dec 07, 2021 - 21:51 CST
Update
We are continuing to monitor for any further issues.
Posted Dec 07, 2021 - 10:30 CST
Update
We are continuing to monitor for any further issues.
Posted Dec 07, 2021 - 10:25 CST
Monitoring
We are currently experiencing login issues due to the global Amazon outage. This issue will prevent you from being able to login to your account or if you are able to login you will likely see errors in the dashboard. There currently isn't an ETA for resolution and we are continuing to monitor the Amazon situation. Thank you for your patience and understanding.
Posted Dec 07, 2021 - 10:22 CST
This incident affected: MxToolbox.com, Mailflow, Service Provider, Alert Notification Engine, API, Supertool, and MXDelivery Center.