Mailflow Issues
Incident Report for MxToolbox, Inc.
Resolved
Mailflow Monitoring ping performance issues were resolved on 11/16/18 at approximately 2:30 pm CST after a partial outage in the Mailflow service affected some monitors. We have been monitoring system performance through the weekend and have not detected any further issues stemming from that partial outage.

If you detect any future performance issues with the Mailflow service please login and open a support ticket or visit our support page at https://mxtoolbox.com/support.aspx
Posted 26 days ago. Nov 18, 2018 - 01:07 CST
Monitoring
An issue occurred while upgrading our backend systems that has caused some inconsistent results with mailflow pings. Users may have seen some missing pings or incorrect status alerts for Mailflow monitors. We are working on resolving these problems.
Posted 27 days ago. Nov 16, 2018 - 13:37 CST
This incident affected: Mailflow.