Degraded Performance and Adding New Delivery Center Domains

Incident Report for MxToolbox, Inc.

Resolved

This incident has been resolved.
Posted Jun 13, 2023 - 16:59 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2023 - 15:39 CDT

Investigating

We are currently experiencing degraded performance and issues with adding new Delivery Center Domains. We are continuing to investigate this issue and will provide updates as they become available.
Posted Jun 13, 2023 - 14:47 CDT
This incident affected: MXDelivery Center.