Mailflow Monitor Problems
Incident Report for MxToolbox, Inc.
Resolved
The issue with mailflow monitors for users with outdated versions of TLS has been resolved. We apologize for any inconvenience this has caused.
Posted 7 months ago. Dec 13, 2017 - 10:40 CST
Investigating
We're aware of some issues causing mailflow problems for some users using an old version of TLS. We're working on resolving these issues.
Posted 7 months ago. Dec 13, 2017 - 08:27 CST