Delivery Center Navigation Menu Links Issue
Incident Report for MxToolbox, Inc.
Resolved
This incident has been resolved.
Posted Mar 29, 2024 - 14:34 CDT
Investigating
We are currently experiencing an issue that is affecting the Delivery Center Navigation Menu that appears to be isolated to the Google Chrome browser. Some of the links or items are missing from the menu and are blue in color. You can resolve this issue by clearing your cache & cookies on the affected browser. Our team is currently investigating this issue.
Posted Mar 27, 2024 - 11:43 CDT
This incident affected: MXDelivery Center.