Issues logging in to MXToolBox site
Incident Report for MxToolbox, Inc.
Resolved
The issue with users unable to log in has now been resolved. We apologize for any inconveniences this may have caused. Have a great day!
Posted May 20, 2022 - 11:04 CDT
Update
We are continuing to investigate this issue.
Posted May 20, 2022 - 11:01 CDT
Investigating
We are currently investigating an issue where users are unable to log in to the website. We apologize for the inconvenience.
Posted May 20, 2022 - 09:57 CDT
This incident affected: MxToolbox.com.