Mimecast DMARC Reporting Issues
Incident Report for MxToolbox, Inc.
Resolved
Our Team identified the data discrepancy from Mimecast DMARC data, and has installed a fix for this issue. It has been tested, deployed and monitored. This issue is now resolved.
Posted Aug 04, 2023 - 16:48 CDT
Investigating
We are currently looking into an issue with the DMARC Reports / Aggregate Data from Mimecast. This issue seems to have started around 7/28/2023. We are not able to populate your DMARC Data with information from Mimecast at this time.
Posted Jul 31, 2023 - 10:41 CDT
This incident affected: MXDelivery Center.