Delivery Center Edit / Modification Permission Issue
Incident Report for MxToolbox, Inc.
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 10:14 CDT
Monitoring
We are continuing to monitor this permissions issue but have implemented a change that has allowed modifications to your settings.
Posted Oct 02, 2024 - 13:28 CDT
Investigating
We are currently experiencing an issue that prevents "Editors" & "Owners" from modifying certain settings in their Delivery Center account (ie: DMARC & SPF settings). Our Product & Engineering Teams are investigating this issue currently. No data is affected by this issue.
Posted Oct 02, 2024 - 10:35 CDT
This incident affected: MXDelivery Center.