Mailflow Outage

Incident Report for MxToolbox, Inc.

Resolved

The Mailflow outage has been resolved. All Mailflow monitors are running as expected.
Posted Aug 16, 2022 - 10:07 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 16, 2022 - 10:04 CDT

Investigating

We are currently investigating a Mailflow system issue that is impacting all Mailflow monitors.
Posted Aug 15, 2022 - 11:27 CDT
This incident affected: Mailflow.