Partial Mailflow Tool Outage
Incident Report for MxToolbox, Inc.
Resolved
This incident has been resolved.
Posted Jun 19, 2019 - 10:17 CDT
Investigating
We are currently investigating an issue with the Mailflow tool not processing the test messages correctly. This is causing some customers to receive alerts that their Mailflow is down.

At this time we do not have an ETA on when the issue will be resolved.
Posted May 07, 2019 - 16:01 CDT
This incident affected: Mailflow.