Mxtoolbox.com Problems
Incident Report for MxToolbox, Inc.
Resolved
We have resolved the issue that was preventing use of the website. All functions have returned to normal.
Posted 10 months ago. Jan 01, 2018 - 12:34 CST
Update
We are currently investigating an issue that is causing performance issues. During this time you are likely to experience extreme slowness with login & lookup times. We will provide updates as they become available.
Posted 10 months ago. Jan 01, 2018 - 10:54 CST
Investigating
We're investigating issues that are preventing users from using the website. We will update this status when we have more information.
Posted 10 months ago. Jan 01, 2018 - 10:35 CST