Yahoo! DMARC Aggregate Data / RUF Reports
Incident Report for MxToolbox, Inc.
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 14:47 CDT
Update
We are continuing to monitor for any further issues.
Posted Jun 13, 2023 - 14:47 CDT
Monitoring
We have identified an issue with the Yahoo! DMARC Report Data and expect a decrease in reported email volumes as a result. This should not have an impact on your mail flow or deliverability, but will cause discrepancies with the reported data.
Posted May 01, 2023 - 10:23 CDT
This incident affected: MXDelivery Center.