As of 10:00 am CST this morning the MxToolbox Mailflow is up and running. However, the service continues to experience a system wide issue related to delayed ping processing. We are currently working to eliminate the backlog of ping messages that were delayed from being processed yesterday as a direct result from the AWS outage. We have added additional resources to help quicken the processing of those delayed ping messages.
The Mailflow Service was impacted by the AWS outage starting around 1:00 am CST on 10/20/25 when AWS services became degraded. The Mailflow Service then experienced a full outage starting around 4:00 am CST when AWS suffered its main outage. AWS EC2 continued to experience an outage during the course of the day on 10/20/25, only resolving around 10:00 CST when full EC2 service was restored. During this time we continued to send and receive Mailflow ping messages, but could only process a small volume of messages during that time. Additionally, a small number of received ping messages were lost due to the AWS outage.
With our system only able to process a limited amount of ping messages during the AWS outage our queue backed up with un-processed ping messages. Once the AWS EC2 outage fully ceased around 10:00 pm CST, we began fully processing the backed up messages.
Our ping processing service from that point struggled to catch fully back up in processing the full backlog of ping messages. Our engineers added additional capacity to help with the processing and now the system has nearly caught back up to fully processing pings as expected.
We are continuing to monitor the service and will have an update when the service is fully caught up on the backlog and operating normally.
Posted Oct 21, 2025 - 14:16 CDT
Update
DMARC processing has been fully restored and is working with normal speed and frequency as of 4:30pm CST 10/20/2025
Posted Oct 21, 2025 - 09:35 CDT
Update
DMARC report processing is currently slow due to continued AWS outage impact. We are still processing them, but at a much slower pace - as such some report data from the last 24 hours may not be available yet.
Posted Oct 21, 2025 - 09:32 CDT
Update
This morning Amazon Web Services (AWS) had a global service outage and many of our services were impacted by that outage. AWS continues to have an ongoing outage on infrastructure that our monitoring service uses causing our Mailflow service to be down and other monitoring services to be degraded at this time. We are monitoring the situation and will keep you apprised when we know more.
Posted Oct 20, 2025 - 10:32 CDT
Identified
The AWS outage was between 2am CST to 5:30am CST...however there are still residual effects of their outage. The MailFlow Monitoring system is still experiencing issues due to the AWS outage.
Posted Oct 20, 2025 - 10:23 CDT
Investigating
We are currently experiencing an issue with our MailFlow Monitoring system, as Amazon "AWS" encountered an outage this morning. We are expecting their outage to be resolved soon.
This AWS outage is causing the false positives. We will provide updates for this issue as they become available.
thank you for your patience and understanding.
Posted Oct 20, 2025 - 10:18 CDT
This incident affected: MxToolbox.com, Mailflow, Alert Notification Engine, API, Supertool, MXDelivery Center, and Monitoring.