MxToolbox Service Unavailable

Incident Report for MxToolbox, Inc.

Resolved

This incident has been resolved.
Posted Jul 29, 2022 - 11:11 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2022 - 11:09 CDT

Investigating

We are currently experiencing a brief outage with our site, and expect it to be resolved and back up within 15 to 30 minutes. You will likely see an "Unavailable" message when trying to access mxtoolbox.com. Thank you for your patience.
Posted Jul 29, 2022 - 10:38 CDT
This incident affected: MxToolbox.com.