MailFlow Monitors Latency Issues

Incident Report for MxToolbox, Inc.

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 15:34 CDT

Update

We are continuing to monitor for any further issues.
Posted Oct 01, 2025 - 13:02 CDT

Monitoring

A fix has been implemented and we are monitoring the performance.
Posted Oct 01, 2025 - 11:14 CDT

Update

We have isolated the issue causing false latency issues with the MailFlow monitoring system, and are testing the resolution. We expect to roll this out soon if tests pass.
Posted Oct 01, 2025 - 10:20 CDT

Identified

We are investigating and issue that caused our MailFlow Monitoring to change our TimeZone to UTC. This is causing MailFlow monitors to report delays even though the do not exist. These are false positives, and our Team is issuing a fix as this is being typed. The behavior shows approximately 18000+ seconds in latency. We expect this to be resolved shortly. Thank you for your patience and understanding.
Posted Oct 01, 2025 - 09:35 CDT
This incident affected: Mailflow.