Support Ticketing Issue - Related to HubSpot Outage

Incident Report for MxToolbox, Inc.

Resolved

This incident has been resolved.
Posted Aug 27, 2024 - 10:30 CDT

Monitoring

Due to a major outage with our Support Ticket vendor Hubspot, our Support Department will be slow to respond to tickets. All of the MxToolbox systems are functioning properly at this time. We are continuing to monitor the issue with our vendor. Thank you for your patience.
Posted Aug 27, 2024 - 10:01 CDT
This incident affected: MxToolbox.com, Mailflow, Service Provider, Alert Notification Engine, API, Supertool, MXDelivery Center, and Monitoring.