Mailflow Monitor Problems
Incident Report for MxToolbox, Inc.
Resolved
All issues related to mailflow have been resolved.
Posted 19 days ago. Aug 01, 2018 - 09:36 CDT
Identified
Our developers are working on some improvements to the maiflow system and have inadvertently impacted some mailflow monitors. They are still working on this system, but expect any further disruption to be minor. We will update this space with more information on any further issues.
Posted 20 days ago. Jul 31, 2018 - 12:01 CDT
This incident affected: Mailflow.