MxToolbox Site Unavailable
Incident Report for MxToolbox, Inc.
Resolved
This incident has been resolved.
Posted Jan 06, 2023 - 13:07 CST
Monitoring
The mxtoolbox.com site is back online and functioning. Our team is continuing to monitor the performance of the site and tools.
Posted Jan 06, 2023 - 11:09 CST
Update
We are continuing to work on a fix for this issue.
Posted Jan 06, 2023 - 10:35 CST
Update
We are continuing to work on a fix for this issue.
Posted Jan 06, 2023 - 10:34 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 06, 2023 - 10:33 CST
Investigating
The mxtoolbox.com site is currently unavailable. Our team is currently working on this issue. We will provide updates as soon as they are available. Thank you for your patience.
Posted Jan 06, 2023 - 10:11 CST
This incident affected: MxToolbox.com, Supertool, MXDelivery Center, and Monitoring.