Issues logging in to MXToolBox site
Incident Report for MxToolbox, Inc.
Resolved
The login issue has been resolved, thank you for your patience.
Posted Feb 08, 2023 - 18:21 CST
Identified
We identified an issue that is affecting users being able to log into the MXToolBox site. A fix is being worked on and should be rolled out by the end of the day. We apologize for the inconvenience.
Posted Feb 08, 2023 - 15:42 CST
This incident affected: MxToolbox.com.