Mailflow Monitoring Tool Issues

Incident Report for MxToolbox, Inc.

Resolved

The Issues affecting Mailflow monitors has been resolved.
Posted Sep 20, 2019 - 11:15 CDT

Investigating

We are currently investigating an issue with the Mailflow tool. Customers should not be alerted at this time and we will update this page once the issue has been resolved. We apologize about any inconvenience.
Posted Sep 19, 2019 - 11:11 CDT
This incident affected: Mailflow.