This incident has been resolved. Abuse.ro was permanently removed from the Blocklist Monitoring service.
Posted Jun 27, 2024 - 10:18 CDT
Update
After monitoring the behavior of the abuse.ro blocklist and the false positives they are issuing, we have disabled that list from our toolbox. This should prevent any further alerts from being issue to you regarding this list.
We will continue to monitor the list's health and stability before re-enabling it for our customers.
Because of the high volume of false positives from abuse.ro our queues are a bit backed up so you may continue to receive already process notifications. Once the queue is done you should not receive any more.
Additionally, these false positives should not have an impact on your email delivery.
Thank you for your patience and understanding.
Posted Jun 26, 2024 - 09:53 CDT
Update
We are continuing to monitor for any further issues.
Posted Jun 26, 2024 - 09:53 CDT
Monitoring
After monitoring the behavior of the abuse.ro blocklist and the false positives they are issuing, we have disabled that list from our toolbox. This should prevent any further alerts from being issue to you regarding this list.
We will continue to monitor the lists health and stability before re-enabling it for our customers.
Additionally, these false positives should not have an impact on your email delivery.