Blacklist Lookups by IP returning Invalid
Incident Report for MxToolbox, Inc.
Resolved
The issue preventing IP blacklist lookups has been resolved.
Posted 28 days ago. Jul 23, 2018 - 14:49 CDT
Identified
We are aware that recent changes have affected blacklist lookups for about 15 minutes. We are implementing a resolution and it should be live shortly.
Posted 28 days ago. Jul 23, 2018 - 14:32 CDT
This incident affected: Supertool.