MailFlow Down

Incident Report for MxToolbox, Inc.

Resolved

The incident with the MailFlow monitors has been resolved and the system is functioning properly now. Thank you for your patience and understanding during our investigation and resolution implementation.
Posted Aug 04, 2025 - 13:57 CDT

Identified

We are releasing a fix that will resolve the MailFlow Monitoring...expected ETA is one hour.
Posted Aug 04, 2025 - 11:03 CDT

Investigating

We are currently investigating an issue that is affecting MailFlow Monitors. Currently they will show as down. This is a false positive that is affecting all MailFlow monitors. We appreciate your patience while we investigate and resolve this issue.
Posted Aug 04, 2025 - 10:33 CDT
This incident affected: Mailflow.