Website viewing issues
Incident Report for MxToolbox, Inc.
Resolved
We have resolved the issue that was affecting the user interface when logged in. We apologize for the inconvenience.
Posted Aug 08, 2019 - 12:47 CDT
Investigating
We are currently investigating an issue with the site rendering properly once you have logged in. We apologize about the inconvenience.
Posted Aug 08, 2019 - 11:59 CDT
This incident affected: MxToolbox.com, Mailflow, Service Provider, Alert Notification Engine, API, Supertool, and MXDelivery Center.