Supertool lookups are returning errors
Incident Report for MxToolbox, Inc.
Resolved
The issue with the Supertool lookups has been resolved. If you are still having issues, please clear your browsers cache and restart it. We apologize about any inconvenience.
Posted 2 months ago. Jun 07, 2018 - 12:06 CDT
Investigating
We are currently investigating an issue with lookups on the MXToolBox Supertool. We apologize about the inconvenience and hope to have the issue resolved as quickly as possible.
Posted 2 months ago. Jun 07, 2018 - 11:41 CDT
This incident affected: Supertool.