The scheduled maintenance has been completed. Thank you for your patience.
Posted Aug 31, 2026 - 21:21 CDT
Update
Beginning maintenance.
Posted Aug 31, 2026 - 19:57 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 31, 2026 - 19:03 CDT
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Aug 31, 2026 - 19:02 CDT
Update
The start window of the maintenance has been pushed back. Updates will be provided as they become available.
Posted Aug 31, 2026 - 19:02 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 31, 2026 - 19:00 CDT
Scheduled
We will be upgrading out databases for improved performance and reliability.
Posted Aug 31, 2026 - 16:34 CDT
This scheduled maintenance affected: MxToolbox.com, Mailflow, Service Provider, Alert Notification Engine, API, Supertool, MXDelivery Center, mailgun Outbound Delivery, and Monitoring.