Mailflow Monitoring Issue

Incident Report for MxToolbox, Inc.

Resolved

This incident has been resolved.
Posted Sep 30, 2020 - 14:28 CDT

Investigating

We are currently investigating an issue with the Mailflow tool. We do not have an ETA on when the issue will be resolved at this time.

We apologize for the inconvenience.
Posted Sep 30, 2020 - 09:30 CDT
This incident affected: Mailflow.