Mailflow Monitor Outage
Incident Report for MxToolbox, Inc.
Update
A fix has been implemented and we believe it the underlying root issues have been resolved. We will be monitoring closely.
Posted 6 days ago. Dec 07, 2018 - 15:20 CST
Monitoring
A fix has been implemented and we believe it the underlying root issues have been resolved. We will be monitoring closely.
Posted 6 days ago. Dec 07, 2018 - 15:19 CST
Identified
The issue has been identified and a fix is being implemented.
Posted 8 days ago. Dec 05, 2018 - 16:42 CST
Investigating
The engineering team is currently investigating an issue that causes MailFlow messages to be improperly processed.
Posted 8 days ago. Dec 05, 2018 - 10:29 CST
This incident affects: Mailflow.