MxDelivery Center & Monitor Site Issues
Incident Report for MxToolbox, Inc.
Resolved
This incident has been resolved, and the systems are fully operational.
Posted Sep 26, 2024 - 16:06 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 26, 2024 - 11:30 CDT
Investigating
We are currently experiencing issues that impact user's abilities to login and access the Monitoring & Delivery Center dashboards. Our Product & Engineering Teams are currently investigating the cause and possible resolution. We currently do not have an ETA, but will provide updates as they become available.

Note: Your domain's configurations, data, and performance are not impacted by this issue.
Posted Sep 26, 2024 - 11:25 CDT
This incident affected: MXDelivery Center and Monitoring.