MXToolBox.com site unavailable
Incident Report for MxToolbox, Inc.
Resolved
The issue has been resolved now for a couple of hours. Sorry for the inconvenience.
Posted Jun 21, 2019 - 13:39 CDT
Investigating
We are currently investigating issues with the mxtoolbox.com site being unavailable. We apologize about the inconvenience.
Posted Jun 21, 2019 - 10:15 CDT
This incident affected: MxToolbox.com.