Error on Managed Domains Page / Delivery Center

Incident Report for MxToolbox, Inc.

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 10:19 CDT

Update

We have released an update to our system that prevents the error from occurring, and are still working on some of the page features for full restoration of the Managed Domains page. We will continue to monitor this issue and fix before we close out this issue. Again thank you for your patience.
Posted Jul 22, 2025 - 09:12 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2025 - 14:44 CDT

Investigating

We are currently investigating and issue that is triggering an error "Oops, we've encountered an Unexpected Error" within the Delivery Center dashboard. This is not impacting any data. It is mainly affecting the Managed Domains page. We appreciate your patience while we work to resolve this issue.
Posted Jul 21, 2025 - 10:31 CDT
This incident affected: MXDelivery Center.