MxToolbox.com down
Incident Report for MxToolbox, Inc.
Resolved
There was a brief issue with one of our data center that caused the site to be inaccessible for a few minutes. This issue has been resolved and all services are operating normally. We apologize for any inconvenience this may have caused.
Posted over 1 year ago. Apr 21, 2016 - 16:05 CDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Apr 21, 2016 - 15:50 CDT