Mxtoolbox.com Website Issues
Incident Report for MxToolbox, Inc.
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 19, 2016 - 13:53 CDT
Monitoring
There is an issue affecting performance of certain functions on mxtoolbox.com related to account functions such as login. The issue has been mitigated and is being monitored by MxToolbox staff.

You can reach MxToolbox Support with any questions or requests at 512-637-8762, support@mxtoolbox.com or http://mxtoolbox.com/support
Posted about 1 year ago. Sep 19, 2016 - 10:35 CDT