MXDelivery Center Dashboard Performance Issues
Incident Report for MxToolbox, Inc.
Resolved
The issue with MXDelivery Center has been resolved. We were having dynamo read errors which caused our aggregate queries to time out, which in turn made Cloud-Front time out.
Posted 2 months ago. Oct 11, 2017 - 10:42 CDT
Investigating
We are currently investigating some MXDelivery Center performance issues that are causing some users to not be able to view their data. Our engineers are currently working on a fix for this issue.
Posted 2 months ago. Oct 11, 2017 - 10:26 CDT