Mailflow Monitor Delays
Incident Report for MxToolbox, Inc.
Resolved
Some customers who use a smarthost (i.e. Mimecast, MXLogic, Proofpoint) may have experienced issues with their Mailflow monitor. The issue was the Forwarded mailflow message was queuing up at the smarthost or you received the error "Too many recipients received this hour". This issue has been resolved. Please let us know if you have any further issues by sending a message to support@mxtoolbox.com.
Posted about 1 year ago. Jul 06, 2016 - 14:42 CDT
Investigating
We've recently updated the delivery routes for the mailflow monitor. This has caused some issues with receiving inbound connections from customers using the Mimecast smarthost. We are working to get the issue resolved as quickly as we can.
Posted about 1 year ago. Jul 06, 2016 - 14:15 CDT