Website access is impaired
Incident Report for MxToolbox, Inc.
Resolved
The issue affecting users logging into the website has been resolved. We apologize for any inconvenience.

You can reach MxToolbox Support with any questions or requests at 512-637-8762, support@mxtoolbox.com or http://mxtoolbox.com/support
Posted 12 months ago. Aug 29, 2016 - 12:27 CDT
Identified
There is an issue affecting access to the website for some users. This issue should be resolved shortly. No monitors are affected.

You can reach MxToolbox Support with any questions or requests at 512-637-8762, support@mxtoolbox.com or http://mxtoolbox.com/support
Posted 12 months ago. Aug 29, 2016 - 11:51 CDT