MxToolbox DDOS Attack
Incident Report for MxToolbox, Inc.
Resolved
We identified the source of the DDOS attack and stopped the offenders. We have monitored the system for 24 hours and have not seen any further occurrences. You can reach MxToolbox Support with any questions at 512-637-8762, support@mxtoolbox.com or http://mxtoolbox.com/support
Posted 7 months ago. Jan 11, 2017 - 16:13 CST
Monitoring
We are investigating what look like a DDOS attack on our systems. We believe this issue is resolved, but we're still monitoring the situation to ensure there are no further problems. You may have experienced problems with the website responding or with Mailflow pings around 10AM Central time this morning.
Posted 7 months ago. Jan 10, 2017 - 15:59 CST