Performance Issues
Incident Report for MxToolbox, Inc.
Resolved
Performance to mxtoolbox.com & SuperTool Lookups has been successfully restored.
Posted 12 months ago. Nov 04, 2016 - 15:57 CDT
Investigating
Our engineers are currently investigating a known performance issue affecting SuperTool lookups and mxtoolbox.com.

We will provide further updates once we know more.
Posted 12 months ago. Nov 04, 2016 - 15:37 CDT